Virtual DJ Studio Home | NGWave Home | Official Facebook Page | Unofficial VDJ Users Group

Author Topic: NGWave playback is 'choppy' on Win 8 64bit  (Read 7681 times)

Offline ORCoastGuy

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
NGWave playback is 'choppy' on Win 8 64bit
« on: November 06, 2014, 08:15:33 AM »
Hello,
I have been using NGWave for nearly 10 years now.  LOVE IT!  I do some work in broadcast, and free-lance audio production.  I also do PA and play music at local sports venues, and of course, have deejayed a wedding or two in my time.  NGWave has served me well for all sorts of editing over the years.   It does things that so-called "professional" systems don't do as easily or intuitively.
Despite my audio skills, I'm not what you would call an "audiophile" especially with the new technology behind the process.  (I learned audio editing with a chop-block, razor blade, and audio tape.)

Here's the situation:  I had been using NGWave 3.4 just fine, on my Windows XP (32-bit) machine for years.
Time for a new computer-- enter Windows 8 (64-bit).  I downloaded and installed NGWave 4.6  (build 20130614) and paid for new registration, which is fine.

Everything functions fine, but my audio playback is slow and "choppy".  (Not sure how to describe it... playing the standard "NGWave.mp3" file that comes with the software, it goes   "N-n-n-n-   G-g-g-g    Wa-wa-wa-wa-ve-ve-ve".)  I get the same result on other files I have tried, both .MP3 and .WAV.

I checked all my settings from the old program to the new.  All the same.

I also thought maybe the "on-board" audio card of the "new" PC was the culprit.  (It's not a new PC, but it is a lot more powerful than the old.)  So I spent about $30 on a nicer audio card-- SoundBlaster Audigy FX.   It installed and is working flawlessly. 
     (OK, then I found this forum, and I see perhaps the SoundBlaster cards might not be the best choice... but my result is the same, so I'm not sure it's the card anyway.)
PC specs--  Pentium 4 processor, 3.0GHz.  4GB RAM.  Plenty of disk space.     I know a P4 processor wasn't really designed with Win8 in mind, but at 3.0GHz, it  seems like it should do the job.  Everything else in Win8 is running flawlessly and fluidly.

Anyone have any ideas or suggestions?    I'm kinda hoping it is something simple.


Offline Fabio

  • Administrator
  • Hero Member
  • *****
  • Posts: 757
  • Karma: 11
    • View Profile
Re: NGWave playback is 'choppy' on Win 8 64bit
« Reply #1 on: November 06, 2014, 04:46:54 PM »
I know you said windows is running fine...but I'm willing to bet it's probably maximizing your resources to do so and there's probably not much left for NGWave.  I wish I had something to test it with so I could tell you for sure.  I use it on Windows 8, but my laptop is a Quad Core i7.

The lowest I got is a Dual Core laptop with Windows 7 and I have run NGWave there before with no problems.

Let's see if anyone else has any other suggestions.



Fabio Q.
Shooting Star Karaoke

Offline Justin

  • Site Administrator
  • Administrator
  • Hero Member
  • *****
  • Posts: 951
  • Karma: 11
    • View Profile
    • Virtual DJ Studio
Re: NGWave playback is 'choppy' on Win 8 64bit
« Reply #2 on: November 07, 2014, 02:57:07 PM »
The truth of the matter is this: NGWave is quite old. I last updated the internal code over 10 years ago, in the XP days. Hence the low price tag if it works for you.

One tip: shrink the window down. Screen resolutions weren't as high 10 years ago (on average), and it's the display code causing the choppy playback.

After I finish up on VDJ7 (getting quite a lot of progress so far btw!) I'll be working on a new audio editor product (changing the name as I let the domain ngwave.com expire...) that will work well with multiple-core and 64-bit operating systems.

As it stands, NGWave still does what it does very well, but it needs some updating to get with the times...
-- Justin Nelson, CEO
   Next Generation Software, Inc.
   http://www.vdj.net/

Offline ORCoastGuy

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
    • View Profile
Re: NGWave playback is 'choppy' on Win 8 64bit
« Reply #3 on: November 09, 2014, 06:21:15 PM »
One tip: shrink the window down. Screen resolutions weren't as high 10 years ago (on average), and it's the display code causing the choppy playback.

BINGO!  That was it.  Thanks, Justin!   Never dawned on me to try that.  I had noticed that the sample playbacks (in the Options) were fine-- that makes sense now, because they are not using all the visual stuff.

Reducing my Windows size, or overall screen resolution, will work for me just fine.   Back to kicking myself for not trying that already....   
Well, hopefully this post will help someone else too.       Thanks again.   Have loved using NGWave the past 9-10 years!